Saturday, 10 June 2017

Synopsys Research highlights the Pervasive Use of Outdated and Insecure Third-Party

Synopsys, Inc. have today released ‘The State of Software Composition 2017’ report, following their recent investigation into the security of the software supply chain- arguably one of the most significant challenges the software industry is currently facing.

Using their own software composition analysis product, Protecode SC,  Synopsys analysed real-world data, over a 12-month period (Jan 1st 2016- Dec 1st 2016). The report details the analysis of 128,782 software applications, subsequently revealing 16,868 unique versions of open source and commercial software components- containing close to 10,000 unique security vulnerabilities.

As Andreas Kuehlmann, senior vice president and general manager for the Synopsys Software Integrity Group explains “By analysing large data sets and identifying trends and problem areas, we are able to provide the software development community with valuable intelligence to help them keep their software secure and up to date”. He added, “Over time, vulnerabilities in third-party components are discovered and disclosed, leaving a previously secure software package open to exploits. The message to the software industry should not be whether to use open source software, but whether you are vigilant about keeping it updated to prevent attacks.”

The research represents a variety of software including mobile, desktop and web applications, as well as firmware and embedded software from a variety of industries.  The report also details information on commonly observed 3rd party software components, the Common Vulnerabilities and Exposures (CVE) known to affect these components, the 10-point Common Vulnerability Scoring System (CVSS) rank for CVE and the Common Software Weaknesses (CWE) used to classify them

Other notable findings detailed in the report include:

  • 45 percent of the total 9,553-specific CVEs date back to 2013 or earlier
  • The Heartbleed bug still appears in the top 50 percent of all CVEs observed, even though a patch has been available since 2014
  • The oldest CVE dates back to 1999
  • The top 10 most common software components with outdated versions still being used more than 90 percent of the time include: Curl, Dropbear, Expat, libjpeg-turbo, libjpeg, libpng Linux Kernal, Lua, OpenSSL, and Pcre; if they are not updated, these software components may leave products vulnerable

Discussing the clear relevance of the report, Robert Vamosi, security strategist at Synopsys explains “coming on the heels of last month’s WannaCry outbreak, the insights in the report serve as a wakeup call that not everyone is using the most secure version of available software”. He added, “The update process does not end at the time of software release, and an ongoing pattern of software updates must be implemented throughout the product lifecycle. As new CVEs are disclosed against open source software components, developers need to know whether their products are affected, and organisations need to prevent the exploit of vulnerabilities with the latest versions when they become available.”

Download the full report here.

The post Synopsys Research highlights the Pervasive Use of Outdated and Insecure Third-Party appeared first on IT SECURITY GURU.



from Synopsys Research highlights the Pervasive Use of Outdated and Insecure Third-Party

No comments:

Post a Comment